Author Topic: Tito Neri speed control setup  (Read 1458 times)

0 Members and 1 Guest are viewing this topic.

alfaman

  • Newbie
  • *
  • Posts: 21
Tito Neri speed control setup
« on: August 10, 2015, 03:31:22 »
I have 2 mtroniks 30 amp tio marine speed controls and johnson 800-900 size brushed motors driving graupner z drives. I tried plugging the two speed controls into a Y connector and had problems with the motors surging,stopping and were  very erratic. What would be the best setup for this tug? I have a futaba 9c computer radio.I put the speed controls on separate channels and created a mix running them both from the left throttle stick and it worked but im wondering now if other Tito owners configure the throttles on two sticks? Any help is appreciated.Im trying to figure out the best method.
Thank You,Tony

EAGLE

  • Newbie
  • *
  • Posts: 10
Re: Tito Neri speed control setup
« Reply #1 on: August 10, 2015, 08:58:22 »
Hi
    If you want to run two motors off two separate sticks. disconnect one of the red wires on your ESCs, if you don't the signals fight each other. Hope this helps.
                 Regards Dave

alfaman

  • Newbie
  • *
  • Posts: 21
Re: Tito Neri speed control setup
« Reply #2 on: August 11, 2015, 12:56:21 »
I disconnected both red wiresfrom each speed control. Have a separate receiver battery.

mike_victoriabc

  • Admiral Poster
  • ******
  • Posts: 1676
Re: Tito Neri speed control setup
« Reply #3 on: August 11, 2015, 20:31:43 »
Have a look at the Action Website - usually a link on the left and go through the wiring diagrams there. Lot of help and you should be good to go. If puzzled - fire away. We have all been there.